読者です 読者をやめる 読者になる 読者になる

localdisk

PHP とか Java とか Web とか好きなことを書きます。

Laravel 4.2 Beta をインストールする

これが一番簡単だと思います。

$ git clone -b develop https://github.com/laravel/laravel.git laravel-beta 
$ cd laravel-beta
$ composer install

変更点等は @HiroKws のツイートをチェックするべし。
注意点ですが、trait を使用しているため PHP5.4 以上になっているのでそこだけ気をつけてください。

追記

今現在開発しているアプリケーションを 4.2 にあげたい人は composer.json を修正しましょう。

{

    "require": {
        "laravel/framework": "4.2.*"
    },
    "minimum-stability": "dev"
}

この2箇所を修正すればOKです。